FIX PROBLEM: Din server kör PHP version, men Wordpress 5.1.6 3.2.1 5.2.4 kräver minst.

Lägg märke till att allt inte är väl känt att för installera eller göra uppgraderaSite till en nyare version av 3.2Det är nödvändigt att installeras en nyare version av 5.2.4.

Om servern är att installera en äldre version av PHP 5.2.4, installationsversionen WordPress 3.2.1Kommer att visas fel / Message "Din server kör PHP version 5.1.6 3.2.1 men Wordpress kräver minst 5.2.4".
Problemet kan lösas mycket enkelt genom att uppgradera PHP, men innan du gör det måste tänka på några saker. Först, uppgradering PHP är möjlig på en delad hosting. Så du kan göra uppgraderingen måste du ha administratörsbehörighet till servern (Dedikerad Server eller VPS). I den andra, innan uppgraderingen måste dokumentera och vara medvetna om att ny version av PHP inte ge fel andra webbplatser finns på den servern.

För Det är det operativsystem som används Webbservrar (Agreart och / WHMA) en show dig hur man gör uppgradera till PHP på CentOS 5.2.10 5-bitars 32.x.

Uppgraderings PHP på CentOS 5.1.x 5.2.x till 5.x 32-bitars

1. Kontrollera vilka paket / moduler är installerade PHP (t.ex. php-mcrypt) i tillägg till standardpaket. Om de finns, kommer att tas bort eller actuzlizate.

Kontroll av installerade paket:

rpm-qa | grep php

old_php_version

2. Lägg slutförvar för Krävs uppgraderaÄr PHP-version.

nano /etc/yum.repos.d/CentOS-Testing.repo

I den nyskapade filen (CentOS-Testing.repo) Kommer att lägga till följande rader (kopiera / klistra in):

[C5-test]
name = CentOS-Testing 5
baseurl = http://dev.centos.org/centos/ $ releasever / testning / $ basearch /
enabled = 1
gpgcheck = 1
gpgkey = http://dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing
includepkgs = php *

Ctrl + X för att spara filen CentOS-Testing.repo.

3. Uppdatera PHP via yum:

yum uppdatering

4. Starta om / httpd :

tjänsten httpd starta

Efter omstart httpd och kontrollera vilken version av installerade paket:

new_php_version

Kontrollera om det finns fel moduler / paket:

php-v

PHP Uppgradering / CentOS 32 bitar (i386).

FIX PROBLEM: Din server kör PHP version, men Wordpress 5.1.6 3.2.1 5.2.4 kräver minst.

Om författaren

stealth LP

Grundare och redaktör stealth SettingsI 2006 datum.
Erfarenhet på Linux-operativsystem (särskilt CentOS), Mac OS X, Windows XP> Windows 10 och Wordpress (CMS).

Lämna en kommentar

Den här sidan använder Akismet för att minska spam. Läs om hur din kommentardata behandlas.