Fixa fel: Din PHP-installation verkar sakna MySQL-förlängningen som krävs av WordPress

"Din PHP-installation verkar sakna MySQL-tillägget som krävs av WordPress”Är ett fel som många blogg- och webbplatsägare stöter på Wordpress.
Detta är inte en anledning till oro. Brist på MySQL-förlängning från PHP är typiskt för operativsystem installerade från grunden, VPS eller dedikerade servrar, där PHP-tillägg inte var en del av installationspaketet. Detta problem finns på båda ubuntu och CentOS. I det här scenariot löses problemet mycket enkelt med en PHP-uppdatering och installationen av modulen "php-mysql".
Uppdatera PHP och installera MySQL-förlängningen på Ubuntu

apt-get update
apt-get install php-mysql

Uppdatera PHP och installera MySQL-förlängningen på CentOS

yum update
yum install php70w-mysql

Efter detta steg, starta om Apache-tjänsten eller nginx.

Jag stötte också på scenariot där även om MySQL-tillägget finns i PHP, visade en blogg som skapades på WordPress felet "Din PHP-installation verkar sakna MySQL-tillägget som krävs av WordPress". För det mesta inträffar felet vid installation av WordPress. Den här gången uppträdde han dock på en blogg som hade varit aktiv i flera år.
I den här situationen fann jag att problemet inte var med PHP-modulerna utan med den mycket gamla versionen av WordPress, som inte längre är kompatibel med PHP 7.4.4RC1. En enkel uppgradering av WordPress till den senaste versionen löste felet.

Fixa fel: Din PHP-installation verkar sakna MySQL-förlängningen som krävs av WordPress

Om författaren

Stealth

Passionerad om allting och IT, jag skriver med glädje om stealthsettings.com sedan 2006 och jag gillar att upptäcka med dig nya saker om datorer och operativsystem macOS, Linux, Windows, iOS och Android.

Lämna en kommentar